Si tu chat de soporte no inicia, por favor agrega +57 al numero de celular

Incident Report for Begranda INC

Resolved

This incident has been resolved.
Posted May 15, 2025 - 10:25 GMT-05:00

Investigating

Si tu chat de soporte no inicia, por favor agrega +57 al numero de celular
Posted May 15, 2025 - 10:12 GMT-05:00
This incident affected: Erp Begranda.